Changes

Jump to navigation Jump to search
550 bytes added ,  04:26, 6 April 2015
m
Mark bug fixed
* WON'T FIX <strike> Owner: ??? {{bug|44174}} Remote X-Window display: command window blank, all other windows fine </strike>
* <strike> Owner: ??? {{bug|44163}} [GUI] Ghost breakpoints in editor </strike>
* <strike> Owner: jwe {{bug|44156}} Don't update GUI Variable Browser Window unless at top-level for performance</strike>
* WON'T FIX <strike> Owner: ??? {{bug|44132}} GUI history pane does not sync with history when using history_control("erasedups") </strike>
* <strike> Owner: ??? {{bug|44123}} In the command window within the GUI, the cursor lags the of any typed command </strike>
* <strike> Owner: ttl {{bug|44103}} Can't open a folder that contains special characters </strike>
* WON'T FIX <strike> Owner: ??? {{bug|44056}} Add more columns to the workspace table </strike>
* WON'T FIX <strike> Owner: ??? {{bug|44040}} GUIeditor: horizontal scroll bar in editor missingdoesn't quite reach the end of very long lines </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43922}} Renaming/deleting a file within the Octave GUI shouldn't trigger the "file has been deleted or renamed"-dialog </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43838}} Object browser in debugger </strike>
* Owner: ??? {{bug|41088}} add a splash screen (loading is non-instantaneous)
* WON'T FIX <strike> Owner: ??? {{bug|41076}} support HTML links in terminal display </strike>
* <strike> Owner: ??? lostbard {{bug|41074}} MinGW: avoid showing terminal window while GUI is loading</strike>
* WON'T FIX <strike> Owner: ??? {{bug|41073}} GUI should show HTML docs not info docs </strike>
* Owner: ??? {{bug|41072}} GUI: improved locale detection
* WON'T FIX <strike> Owner: ??? {{bug|40343}} Suggestion: Add XInitThreads() call before starting the QT based GUI. </strike>
* WON'T FIX <strike> Owner: ??? {{bug|39935}} dialog button order incorrectly changes depending on CLI or GUI </strike>
* <strike> Owner: ??? jwe {{bug|39646}} intermediate workspace display overload when executing 'test'</strike>
* Owner: ??? {{bug|39179}} Warn or fall back to external editor if built without QScintilla
* <strike> Owner: ??? {{bug|38305}} Conflicts between octave's SIGCHLD handler and qt process handling</strike>* <strike> Owner: ??? {{bug|37401}} Multi-line command recall is weird in GUI editor; non-GUI is OK.</strike>
* <strike> Owner: ??? {{bug|37354}} Add support for multiple octave interpreters in one gui window </strike>
* WON'T FIX <strike> Owner: ??? {{bug|35619}} Link error in 'Terminal' tab with the corresponding m-file </strike>
== Bugs related to Windows OS ==
* <strike> Owner: ??? {{bug|44206}} test complex.tst fails in MXE-octave</strike>
* <strike> Owner: rik {{bug|44125}} mxe-octave: fltk printing displays line dropouts in dev version </strike>
* <strike> Owner: ??? {{bug|44118}} imwrite saves wrong pixel values into jpg file </strike>
* <strike> Owner: ??? {{bug|44075}} buid mxe-octave fails "Failed to build package nsis" </strike>
* <strike> Owner: ??? {{bug|43979}} test unpack fails in MXE-Octave ver 4.1.0+</strike>
* WON'T FIX <strike> Owner: ??? {{bug|43651}} special character (diameter sign) in plot produces warning or doesn't show up </strike>
* <strike> Owner: ??? {{bug|43525}} mxe-octave: compile with OpenBLAS with OMP enabled</strike>
* WON'T FIX <strike> Owner: ??? {{bug|43318}} [MinGW] "unknown type name 'int64_t'" with --enable-64 when compiling some OF packages </strike>
* Owner: ??? {{bug|43036}} popen2 on Windows fails quietly if command writes to stderr
* Owner: ??? {{bug|41129}} similar warnings repeated over and over while loading OF pkgs
* WON'T FIX <strike> Owner: ??? {{bug|40726}} <Tab> complete uses incorrect file separator on Windows </strike>
* WON'T FIX <strike> Owner: ??? {{bug|40444}} On Windows, config & history files etc. should go to %APPDATA%</strike>
* <strike> Owner: ??? {{bug|40443}} MinGW: Octave crashes on exit after GraphicsMagick tests </strike>
* WON'T FIX <strike> Owner: ??? {{bug|39856}} Cannot compile an Oct-File in Windows 7 64 or Vista 64 oct file</strike>
* WON'T FIX <strike> Owner: ??? {{bug|39004}} GUI: limitations of selecting text in terminal widget in Windows </strike>
* WON'T FIX <strike> Owner: ??? {{bug|37053}} Saveas & Print error when saving as .emf </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43505}} build gm with quantum-depth=16 in mxe octave </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43298}} LLVM 3.5.0 cannot resolve the pow(octave_int<int>, octave_Int<int>) function overload </strike>
* <strike> Owner: mtm {{bug|43279}} Please install the supplied AppData file</strike>
* WON'T FIX <strike> Owner: ??? {{bug|43250}} Octave fails to build with Intel Compiler </strike>
* <strike> Owner: mtm {{bug|43087}} improve support for reproducible builds</strike>
* <strike> Owner: mtm {{bug|43063}} Suitesparse 4.3.x has changed APIs, no longer builds with Octave </strike>
* <strike> Owner: ??? {{bug|43003}} polyfit error.... 64 bit problem? </strike>
* <strike> Owner: ??? {{bug|42995}} building Octave with SGI MipsPro 7.3 CC </strike>
* <strike> Owner: mtm {{bug|42176}} Octave built without OpenMP crashes when unloading OpenMP-enabled oct-files</strike>
* WON'T FIX <strike> Owner: ??? {{bug|42057}} qMin compilation error with --enable-64 </strike>
* <strike> Owner: rik {{bug|41665}} 'qt' is default graphics toolkit even when it is not available </strike>
* Owner: ??? {{bug|41027}} config.h is too generic
* WON'T FIX <strike> Owner: ??? {{bug|40273}} 'sed' is used even if a different value for 'SED' is specified during configure </strike>
* WON'T FIX <strike> Owner: mtm {{bug|40252}} Make GUI compatible with both Qt4 and Qt5</strike>
* WON'T FIX <strike> Owner: ??? {{bug|40111}} Support runtime selection of Java version on Linux and Unix systems </strike>
* WON'T FIX <strike> Owner: ??? {{bug|39446}} MXE-Octave: LAPACK build mixes MinGW and MSVC </strike>
== Bugs with severity >= 4 ==
* <strike> Owner: ??? {{bug|44330}} Qt toolkit segmentation fault when figure opened, closed, and opened again </strike>* <strike> Owner: ??? {{bug|44296}} Windows segmentation fault with dl.exe</strike>
* Owner: ??? {{bug|44292}} Frequent crashes when printing to eps on Windows platform
* <strike> Owner: lostbard {{bug|44215}} README.html for NSIS install needs update </strike>
* <strike> Owner: jwe {{bug|44015}} GUI crashes after clear all in right click menu </strike>
* Owner: ??? {{bug|43769}} error: invalid meta.package indexing when using strfind function
* <strike> Owner: ??? {{bug|43741}} different results from power operator in mxe-octave GUI/CLI</strike>
* WON'T FIX <strike> Owner: ??? {{bug|42596}} OpenGL toolkits for the GUI on MacOS X </strike>
* <strike> Owner: jwe {{bug|42537}} print backend needed for qt toolkit </strike>
* WON'T FIX <strike> Owner: ??? {{bug|42469}} GUI crashes on international character after autocompletion</strike>
* <strike> Owner: jwe {{bug|41977}} '__qt_ginput__' not found </strike>
* Owner: ??? {{bug|41699}} imformats causes a segmentation fault on Windows when Octave exits
911

edits

Navigation menu