Changes

Jump to navigation Jump to search
343 bytes added ,  14:06, 24 March 2020
Line 2: Line 2:     
= Installation =
 
= Installation =
== package requirements ==
+
== Package requirements ==
 
This package requires Octave 3.6 or later.
 
This package requires Octave 3.6 or later.
   −
== octave installation ==
+
== Octave installation ==
    
The package may already be installed if you are using the mxe-octave based installation of windows.
 
The package may already be installed if you are using the mxe-octave based installation of windows.
   −
To verify, from octave commmand line:
+
To verify, from octave command line:
    
  >> pkg install list windows  
 
  >> pkg install list windows  
      −
To install from octave commmand line:
+
To install from octave command line:
   −
  >> pkg install -forge windows
+
  >> pkg -forge install windows
    
= Using it =
 
= Using it =
Line 23: Line 23:     
  >> pkg load windows
 
  >> pkg load windows
 +
 +
 +
== Simple example ==
 +
 +
This example uses the com interface to display the current directory.
 +
 +
  wshell = actxserver ("WScript.Shell");
 +
  wshell.CurrentDirectory
 +
 +
 +
= Documentation =
 +
 +
Documentation and reference for the Windows package is available on [https://octave.sourceforge.io/windows/overview.html Octave forge]
 +
 +
[[Category:Octave Forge]]
Anonymous user

Navigation menu