Octave for Debian systems

From Octave
Revision as of 18:19, 7 September 2013 by JasonHnicholson (talk | contribs) (Fixing grammar)
Jump to navigation Jump to search

For Debian, and Debian based distributions such as Ubuntu, specific solutions.

Pre-compiled binaries

Binary packages for Octave and many Octave-Forge packages are provided by all versions of Debian and Ubuntu. These are the most well-tested binaries available and should work best for most users.

Octave is often split over multiple packages to cover the different parts of it. Aside the octave package that installs GNU Octave, there is also octave-doc, octave-info, and octave-htmldoc for the documentation, liboctave-dev for the octave development library (required to install most packages), and octave-dbg for the debugging symbols.

Troubleshooting

When installing Octave 3.2 in Ubuntu, broken packages install may cause an error: `pkg' undefined error, previously reported as bug 465005:

...
Setting up octave3.2 (3.2.2-2build1) ...
error: `pkg' undefined near line 0 column 1

dpkg: error processing octave3.2 (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for menu ...
Errors were encountered while processing:
 octave3.2
E: Sub-process /usr/bin/dpkg returned an error code (1)

Fix this by complete reinstall:

sudo apt-get --purge remove octave3.2
sudo apt-get --purge remove octave3.2-common
sudo apt-get install octave3.2

Octave's PPA

However, for some Ubuntu releases the octave packages are old. The GNU Octave Team on Launchpad maintain a PPA providing a binary packages of the latest stable and unstable versions of Octave for all versions of Ubuntu. To set up your system to install these packages

sudo apt-add-repository ppa:octave/stable
sudo apt-add-repository ppa:octave/unstable
sudo apt-get update
sudo apt-get install octave

Compiling from source

The only tricky part is to install the dependencies. Once that is solved, installing from source should be as easy as ./configure && make && make install. See the manual for the configure options.

Dependencies

Info icon.svg
different Debian versions may have slightly different package names but their differences should be pretty small, mostly limited to version numbers.

The easy way

The easy way to install most of the necessary dependencies is to sudo apt-get build-dep octave. This will install all packages necessary to build and prepare a Debian package for the octave version available on your system repositories. However:

  • will install unecessary packages related to the building of a Debian package;
  • may miss some new dependencies;
  • may install packages that are no longer octave dependencies.

The right way

The best way is to select and install all the dependencies as listed in the INSTALL.OCTAVE file. The following are their package names in Debian repositories (they will have their own dependencies which your package maintainer will solve automatically).

Warning icon.svg
Debian repositories has several libraries for dealing with HDF data files. The recommended is libhdf5-serial-dev. However, the msh package requires gmsh which is incompatible with it.
Warning icon.svg
the GraphicsMagick++ library (libgraphicsmagick++-dev) on the Debian repositories was compiled with quantum 8 which limits reading images to 8 bit. The solution is to recompile GraphicsMagick with quantum 32.
Info icon.svg
if only the native graphics toolkit will be used, gnuplot will not be necessary.
  • build tools
g++ gcc gfortran make
  • external packages
libblas-dev liblapack-dev libpcre3-dev
  • optional but strongly recommended. Check the Octave manual for more information on them. Packages marked with * are virtual packages (you'll have to pick one of the displayed versions).
Dependency Debian Squeeze Ubuntu X
ARPACK libarpack2-dev
cURL libcurl4-gnutls-dev
FFTW3 libfftw3-dev
FLTK libfltk-dev *
fontconfig libfontconfig1-dev
FreeType libfreetype6-dev
GLPK libglpk-dev
GNU Readline libreadline-dev
gnuplot gnuplot
GraphicsMagick++ libgraphicsmagick++-dev
HDF5 libhdf5-serial-dev
OpenGL libgl-dev *
Qhull libqhull-dev
QRUPDATE libqrupdate-dev
SuiteSparse libsuitesparse-dev
makeinfo texinfo
zlib zlib1g-dev

Building development version

If you are building development versions, you'll require some more packages as listed on etc/HACKING and INSTALL. Many of them will already be installed on your system.

Note that the current development release you shuld run ./bootstrap instead of the old ./autogen

  • development tools
autoconf automake bison flex gperf gzip libtool make perl rsync tar
  • dependencies for the development release
Dependency Debian Squeeze Ubuntu X
GTK theme? gtk2-engines-pixbuf
Java JDK openjdk-7-jdk
LLVM libfftw3-dev
QScintilla libqscintilla2-8
Qt libqtcore4 libqtwebkit4 libqt4-network libqtgui4