Changes

Jump to navigation Jump to search
1,838 bytes removed ,  21:49, 20 June 2015
*The plot octave-forge package still have ginput code although the ginput function is now merge into octave itself. Therefore conflict occur if the plot package is installed. To avoid this problem, rename 'ginput.m' in the folder <code>..\Octave\3.2.4_gcc-4.4.0\share\octave\packages\plot-1.0.7</code>, for example ginput.ob.m. In some computers which has one core CPU, response of ginput is very slow. In the case, modify '__gnuplot_ginput__.m' according to the following thread. http://old.nabble.com/ginput-on-Octave-3.2.4-mingw32-to28093888.html
*From gnuplot-4.4.0, the default terminal of gnuplot for windows is the wxt terminal. Some users may set the GNUTERM environmental variable for the windows terminal being default. The gnuplot for windows allows to set GNUTERM to 'win' (abbreviated form) but octave does not recognize the abbreviated form for terminal name. If one would like set GNUTERM to windows terminal, one should specify it as 'windows' (full form) but not 'win' (abbreviated form). In detail see the following thread: http://old.nabble.com/flicking-problem-again-Octave-3.2.4-mingw32-td28038688.html
 
==Octave on Cygwin==
=== Octave 4.0.0 on cygwin===
 
*'''Web-Site:''' http://cygwin.com
*'''Maintainer:''' Marco Atzeri
*'''Latest release:''' 2015-06-21
 
*Latest packages:
 
:octave-4.0.0-1
:Its announce on cygwin mailing list[http://www.cygwin.com/ml/cygwin-announce/2015-06/]
 
:octave-forge packages have each a cygwin package
:Its announce on cygwin mailing list[http://cygwin.com/ml/cygwin-announce/2015-06/]
: Full cygwin package list is available here[https://cygwin.com/packages/]
: At today 2015-06-21, 57 forge packages are available.
 
*To install :
: run cygwin setup-x86.exe (for cygwin 32 bit) or setup-x86_64.exe (for cygwin 64 bit)
: and select them in the Math category.
: All the package dependencies will be also installed.
 
:Graphics is based on X and to plot you need to start octave within xterm (or similar).
: I recommend to install "xinit", "xlaunch" and "gnuplot".
: These packages will pull all the functional Xserver.
: Otherwise the only graphics will be ASCII art ;-)
 
====Notes====
 
*When building from development source (default branch)
: "make check"
:passes almost all the tests.
:Only, and not substantial, failures are:
<nowiki>
/pub/hg/octave/src/data.cc : 8 failures due to different handling of complex Inf on sort
/pub/hg/octave/src/syscalls.cc: 1 failure on fork. This disappears when octave is installed
/pub/hg/octave/scripts/sparse/svds.m: 1 failure due to test sensitivity on starting point. See
https://mailman.cae.wisc.edu/pipermail/octave-maintainers/2011-September/024715.html</nowiki>
 
*To build from cygwin source package, you need to install "cygport" and the relevant development libraries
<nowiki>
$ tar -xvjf octave-4.0.0-1-src.tar.bz2
$ cygport octave.cygport almostall</nowiki>
 
:see cygport documentation for further info.
==Octave with Visual Studio==
18

edits

Navigation menu