Changes

Jump to navigation Jump to search
Table alignement was incorrect.
Line 1: Line 1:  
:''This article is about using pre-built installers of Octave for Windows; for instructions about building it, see [[Windows Installer]].''
 
:''This article is about using pre-built installers of Octave for Windows; for instructions about building it, see [[Windows Installer]].''
   −
Windows installers are available for the latest version of Octave ({{Release}}, released on {{Release Date}}) from https://ftp.gnu.org/gnu/octave/windows/. Users are encouraged to use the latest version unless a specific feature or requirement warrants using an older version of the software. Version specific instructions and installation notes are provided below.
+
{{Note|Windows installers are available for the latest version of '''Octave ({{Release}}, released on {{Release Date}})''' from https://ftp.gnu.org/gnu/octave/windows/.}}
 +
 
 +
Users are encouraged to use the latest version unless a specific feature or requirement warrants using an older version of the software. Version specific instructions and installation notes are provided below.
 +
 
 +
:'''Note:''' As of version 4.4.1, '''Octave no longer supports Windows XP'''. There may be some workarounds to get Octave installed and running in command line mode (see Bug {{bug|54662}}), but maintainers cannot provide support and troubleshooting for this beyond what has already been documented.
    
=Installers for Microsoft Windows=
 
=Installers for Microsoft Windows=
Line 23: Line 27:  
A typical output (for version {{Release}}) is:
 
A typical output (for version {{Release}}) is:
 
                                                                                              
 
                                                                                              
  Package Name         | Version | Installation directory
+
  Package Name       | Version | Installation directory
 
  --------------------+---------+-----------------------
 
  --------------------+---------+-----------------------
 
     communications  |  1.2.1 | C:\Octave\OCTAVE~1.0-W\mingw64\share\octave\packages\communications-1.2.1
 
     communications  |  1.2.1 | C:\Octave\OCTAVE~1.0-W\mingw64\share\octave\packages\communications-1.2.1
Line 71: Line 75:  
             windows  |  1.3.0 | C:\Octave\OCTAVE~1.0-W\mingw64\share\octave\packages\windows-1.3.0
 
             windows  |  1.3.0 | C:\Octave\OCTAVE~1.0-W\mingw64\share\octave\packages\windows-1.3.0
 
             zeromq  |  1.3.0 | C:\Octave\OCTAVE~1.0-W\mingw64\share\octave\packages\zeromq-1.3.0
 
             zeromq  |  1.3.0 | C:\Octave\OCTAVE~1.0-W\mingw64\share\octave\packages\zeromq-1.3.0
 +
 +
If Octave was installed from a zip of 7z archive, you may need to run:
 +
 
 +
  >> pkg rebuild
    
All packages can be updated to the latest version by running:
 
All packages can be updated to the latest version by running:
Anonymous user

Navigation menu