Talk:Octave for Debian systems

From Octave
Revision as of 01:07, 28 May 2018 by KaKiLa (talk | contribs) (→‎Qt5 in Ubunutu 18.04 LTS)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Qt5 in Ubunutu 18.04 LTS[edit]

List of Qt dependecies in Ubuntu 18.04 LTS Adapt from Debian https://salsa.debian.org/pkg-octave-team/octave/blob/master/debian/control

I installed these:

  • libqscintilla2-qt5-dev
  • libqt5scintilla2-dev
  • qtbase5-dev
  • qttools5-dev
  • libqt5gui5
  • libqt5core5a
  • libqt5webkit5
  • libqt5network5
  • libqt5opengl5-dev
  • libqt5help5

KaKiLa (talk) 13:26, 9 May 2018 (PDT)

The following was enough in another installation

   sudo apt install libsundials-dev qtbase5-dev qttools5-dev qttools5-dev-tools libqscintilla2-qt5-dev libqt5opengl5-dev

KaKiLa (talk) 01:07, 28 May 2018 (PDT)