Difference between revisions of "Plot comparison"

From Octave
Jump to navigation Jump to search
(removed links to diary)
Line 10: Line 10:
  
 
* [http://tech-chat.de/compare_plot_demos/gnuplot/hold_07_1.png gnuplot] + [http://tech-chat.de/compare_plot_demos/fltk/hold_07_1.png fltk]: hold_07_1: red rectangle hides the '^' plot markers. In ML they disappear on-screen as soon as xlim is changed or zoomed. Is this a ML bug? What is the prefered behaviour?
 
* [http://tech-chat.de/compare_plot_demos/gnuplot/hold_07_1.png gnuplot] + [http://tech-chat.de/compare_plot_demos/fltk/hold_07_1.png fltk]: hold_07_1: red rectangle hides the '^' plot markers. In ML they disappear on-screen as soon as xlim is changed or zoomed. Is this a ML bug? What is the prefered behaviour?
 +
 +
* [http://tech-chat.de/compare_plot_demos/matlab/patch_04_1.png gnuplot+ftlk/patch_04_1]: the demo incorrectly assumes the patch "facecolor" is "flat" as octave currently sets this by default (whereas in matlab "facecolor" is "none" by default). This should be fixed with [http://savannah.gnu.org/bugs/index.php?42159 bug#42159]
  
 
== gnuplot only differences ==
 
== gnuplot only differences ==

Revision as of 01:01, 4 July 2014

Visual comparison of plot files from http://tech-chat.de/compare_plot_demos/. You can find the scripts which are used to create these plots in the default branch in scripts/testfun/private.

Here is the generated fltk/dump.m as example.

needs some work

  • gnuplot + ftlk: fill_01_1, fill_02_1: hidden edges keep visible in ML, not with fltk or gnuplot. This seems to be a ML bug when printing to PNG or JPEG and works (same output like gnuplot+fltk) when printing to ps. In FLTK the on-screen images shows the hidden edge and becomes invisible when printing.
  • gnuplot + fltk: hold_07_1: red rectangle hides the '^' plot markers. In ML they disappear on-screen as soon as xlim is changed or zoomed. Is this a ML bug? What is the prefered behaviour?
  • gnuplot+ftlk/patch_04_1: the demo incorrectly assumes the patch "facecolor" is "flat" as octave currently sets this by default (whereas in matlab "facecolor" is "none" by default). This should be fixed with bug#42159

gnuplot only differences

There are a lot of gnuplot differences and it might be nice to fix those, but someone would have to take an interest. Octave is moving towards OpenGL for all plotting so most developers focuses on bug fixes for that toolkit.

Nevertheless here are some visual gnuplot ONLY problems which need some attention:

  • gnuplot ezsurf_02_1: distorted despite "axis equal"
  • gnuplot isosurface_01_1: wrong scale, edges missing

work in progress

  • plotyy_03: chunky dashed line for the '--' linestyle: Thread on ML

fixed

won't fix or Octave only feature

  • gnuplot/ML axis_09, axis_10, axis_11, axis_12, axis_13: No, [x,y]axislocation' 'zero' (http://savannah.gnu.org/bugs/?40588). This is an Octave (and gnuplot) only feature. We can either blacklist, or visually skip over the comparison since it is blank for Matlab. Perhaps should be removed from demos or blacklist axis_09 in dump.m script
  • matlab comet3_01_1, comet_01_1.png: Only the beginning of the animation is printed. Matlab implements comet in a completely different way which means printing isn't really possible for them.