Difference between revisions of "Odepkg"

From Octave
Jump to navigation Jump to search
m (Rename "Octave-Forge" to "Octave Forge" (https://lists.gnu.org/archive/html/octave-maintainers/2018-08/msg00138.html).)
(Update information and link some more recent sources.)
Line 1: Line 1:
[https://bitbucket.org/odepkg/odepkg odepkg] is part of the Octave Forge project. It contains additional functions for numerically solving ordinary differential equations.
+
[https://bitbucket.org/odepkg/odepkg odepkg] was part of the [[Octave Forge]] project. It contains additional functions for numerically solving ordinary differential equations.
  
The most recent official release is [https://octave.sourceforge.io/download.php?package=odepkg-0.8.5.tar.gz version 0.8.5], which however is out of date (it includes functions which have been transferred to core Octave) and [https://savannah.gnu.org/bugs/?func=detailitem&item_id=46309 will] [https://savannah.gnu.org/bugs/?func=detailitem&item_id=48280 not] [https://savannah.gnu.org/bugs/?func=detailitem&item_id=50684 install] at all with recent compilers and versions of Octave.
+
The most recent official release of the ''odepkg'' is [https://octave.sourceforge.io/download.php?package=odepkg-0.8.5.tar.gz version 0.8.5], which however is out of date and [https://savannah.gnu.org/bugs/?func=detailitem&item_id=46309 will] [https://savannah.gnu.org/bugs/?func=detailitem&item_id=48280 not] [https://savannah.gnu.org/bugs/?func=detailitem&item_id=50684 install] with recent compilers and versions of Octave.
  
If you attempt to install odepkg using pkg install -forge, you will get an error such as the following.
+
Some functions of the original ''odepkg''  [[Move some ODE package functions from Octave-Forge to core|have been transferred to core Octave]] in the versions [[Release History|4.2 and 4.4]].  Those are:
 +
 
 +
* {{Manual|ode15i}}
 +
* {{Manual|ode15s}}
 +
* {{Manual|ode23}}
 +
* {{Manual|ode45}}
 +
* {{Manual|odeget}}
 +
* {{Manual|odeset}}
 +
* {{Manual|odeplot}}
 +
 
 +
If you attempt to install ''odepkg'' using <code>pkg install -forge</code>, you will get the following error:
  
 
  error: get_forge_pkg: package not found: "odepkg".
 
  error: get_forge_pkg: package not found: "odepkg".
  
Until a new official release is made, Octave 4.2.x users might consider installing a development snapshot of the package, as follows:
+
== BitBucket repository ==
 +
 
 +
Some further development on the ''odepkg'' takes place on https://bitbucket.org/odepkg/odepkg.  One can install that version for:
 +
 
 +
* Octave 4.2:
  
 
  <nowiki>
 
  <nowiki>
 
  [fname, success] = urlwrite ("https://bitbucket.org/odepkg/odepkg/get/default.tar.gz", [P_tmpdir "/odepkg.tar.gz"]);
 
  [fname, success] = urlwrite ("https://bitbucket.org/odepkg/odepkg/get/default.tar.gz", [P_tmpdir "/odepkg.tar.gz"]);
 
  assert (success)
 
  assert (success)
  pkg ("install", fname)
+
  pkg ("install", fname)</nowiki>
</nowiki>
 
  
To install under the 4.3.0+ development version of Octave one can use the following instead:
+
* Octave 4.4 and newer:
  
 
  <nowiki>
 
  <nowiki>
 
  [fname, success] = urlwrite ("https://bitbucket.org/odepkg/odepkg/get/octave43.tar.gz", [P_tmpdir "/odepkg.tar.gz"]);
 
  [fname, success] = urlwrite ("https://bitbucket.org/odepkg/odepkg/get/octave43.tar.gz", [P_tmpdir "/odepkg.tar.gz"]);
 
  assert (success)
 
  assert (success)
  pkg ("install", fname)
+
  pkg ("install", fname)</nowiki>
</nowiki>
+
 
 +
== See also ==
 +
 
 +
* https://bitbucket.org/odepkg/odepkg Most recent development repository
 +
* https://sourceforge.net/p/octave/odepkg Outdated development repository
 +
* [[media:odepkg.pdf|odepkg: Present and Future]] (Jacopo Corno)
  
  
 
[[Category:Octave Forge]]
 
[[Category:Octave Forge]]

Revision as of 00:00, 4 December 2019

odepkg was part of the Octave Forge project. It contains additional functions for numerically solving ordinary differential equations.

The most recent official release of the odepkg is version 0.8.5, which however is out of date and will not install with recent compilers and versions of Octave.

Some functions of the original odepkg have been transferred to core Octave in the versions 4.2 and 4.4. Those are:

If you attempt to install odepkg using pkg install -forge, you will get the following error:

error: get_forge_pkg: package not found: "odepkg".

BitBucket repository

Some further development on the odepkg takes place on https://bitbucket.org/odepkg/odepkg. One can install that version for:

  • Octave 4.2:
 [fname, success] = urlwrite ("https://bitbucket.org/odepkg/odepkg/get/default.tar.gz", [P_tmpdir "/odepkg.tar.gz"]);
 assert (success)
 pkg ("install", fname)
  • Octave 4.4 and newer:
 [fname, success] = urlwrite ("https://bitbucket.org/odepkg/odepkg/get/octave43.tar.gz", [P_tmpdir "/odepkg.tar.gz"]);
 assert (success)
 pkg ("install", fname)

See also