Difference between revisions of "Building"

From Octave
Jump to navigation Jump to search
Line 31: Line 31:
 
! License / Copyright
 
! License / Copyright
 
! Version
 
! Version
! Debian
+
! [[Debian]]
 +
! [[Arch Linux]]
 
! Level
 
! Level
 
! Recent CVE ?
 
! Recent CVE ?
Line 41: Line 42:
 
|
 
|
 
| {{codeline|build-essential}}
 
| {{codeline|build-essential}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 49: Line 51:
 
|
 
|
 
| {{codeline|make}}
 
| {{codeline|make}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 57: Line 60:
 
|
 
|
 
| {{codeline|awk}}, {{codeline|sed}}, ...
 
| {{codeline|awk}}, {{codeline|sed}}, ...
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 65: Line 69:
 
|
 
|
 
| {{codeline|bison}}
 
| {{codeline|bison}}
 +
|
 
| style="background:green" |  
 
| style="background:green" |  
 
| none
 
| none
Line 73: Line 78:
 
|
 
|
 
| {{codeline|flex}}
 
| {{codeline|flex}}
 +
|
 
| style="background:green" |  
 
| style="background:green" |  
 
| none
 
| none
Line 81: Line 87:
 
|
 
|
 
| {{codeline|autoconf}}
 
| {{codeline|autoconf}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 89: Line 96:
 
|
 
|
 
| {{codeline|automake}}
 
| {{codeline|automake}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 97: Line 105:
 
|
 
|
 
| {{codeline|libtool}}
 
| {{codeline|libtool}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 106: Line 115:
 
|
 
|
 
| {{codeline|libatlas-base-dev}}
 
| {{codeline|libatlas-base-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 114: Line 124:
 
|
 
|
 
| {{codeline|liblapack-dev}}
 
| {{codeline|liblapack-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 122: Line 133:
 
|
 
|
 
| {{codeline|libpcre3-dev}}
 
| {{codeline|libpcre3-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 130: Line 142:
 
|
 
|
 
| {{codeline|libreadline-dev}}
 
| {{codeline|libreadline-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| none
 
| none
Line 138: Line 151:
 
|
 
|
 
| {{codeline|libarpack2-dev}}
 
| {{codeline|libarpack2-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 146: Line 160:
 
| > 7.32.00
 
| > 7.32.00
 
| {{codeline|curl}}
 
| {{codeline|curl}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| [http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4545 CVE-2013-4545]
 
| [http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4545 CVE-2013-4545]
Line 154: Line 169:
 
|
 
|
 
| {{codeline|libfftw3-dev}}
 
| {{codeline|libfftw3-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 162: Line 178:
 
|
 
|
 
| {{codeline|libfltk1.3-dev}}
 
| {{codeline|libfltk1.3-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 170: Line 187:
 
|
 
|
 
| {{codeline|fontconfig}}
 
| {{codeline|fontconfig}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 178: Line 196:
 
|
 
|
 
| {{codeline|libfreetype6-dev}}
 
| {{codeline|libfreetype6-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 186: Line 205:
 
|
 
|
 
| {{codeline|libglpk-dev}}
 
| {{codeline|libglpk-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| none
 
| none
Line 194: Line 214:
 
|
 
|
 
| {{codeline|gnuplot}}
 
| {{codeline|gnuplot}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 202: Line 223:
 
| > 1.3.18
 
| > 1.3.18
 
| {{codeline|libgraphicsmagick++1-dev}}
 
| {{codeline|libgraphicsmagick++1-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| [http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4589 CVE-2013-4589]
 
| [http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4589 CVE-2013-4589]
Line 210: Line 232:
 
|
 
|
 
| {{codeline|libhdf5-dev}}
 
| {{codeline|libhdf5-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| none
 
| none
Line 218: Line 241:
 
|
 
|
 
| {{codeline|libgl-dev}}
 
| {{codeline|libgl-dev}}
 +
|
 
| style="background:red" |  
 
| style="background:red" |  
 
| none
 
| none
Line 226: Line 250:
 
|
 
|
 
| {{codeline|libqhull-dev}}
 
| {{codeline|libqhull-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| none
 
| none
Line 234: Line 259:
 
|
 
|
 
| {{codeline|libqrupdate-dev}}
 
| {{codeline|libqrupdate-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| none
 
| none
Line 242: Line 268:
 
|
 
|
 
| {{codeline|libsuitesparse-dev}}
 
| {{codeline|libsuitesparse-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| none
 
| none
Line 250: Line 277:
 
|
 
|
 
| {{codeline|zlib1g-dev}}
 
| {{codeline|zlib1g-dev}}
 +
|
 
| style="background:yellow" |  
 
| style="background:yellow" |  
 
| none
 
| none

Revision as of 07:08, 19 December 2013

General information about building the Octave source for different operating systems.

We try to keep build instructions up to date in the source tree. Please clone using Mercurial or download it to see the README.

There are also instructions in the manual.

Dependencies

Critical  
Recommended  
Not critical  
Task Name Usage License / Copyright Version Debian Arch Linux Level Recent CVE ?
Build tools C++, C, and Fortran compilers Compiling the source code GNU GPL v3.0 build-essential   none
GNU Make Makefile processor GNU GPL v3.0 make   none
AWK, sed, and other Unix utilities Miscellaneous tasks GNU GPL v3.0 awk, sed, ...   none
Bison Parser generator GNU GPL v3.0 bison   none
Flex Lexical analyzer The Flex project flex   none
Autoconf Software configuration GNU GPL v3.0 autoconf   none
Automake Makefile generator GNU GPL v3.0 automake   none
Libtool Dependency of automake Free Software Foundation libtool   none
External tools BLAS Basic Linear Algebra Subroutine library Free - proper attribution request libatlas-base-dev   none
LAPACK Linear Algebra Package Free - proper attribution request liblapack-dev   none
PCRE Perl Compatible Regular Expression library Free libpcre3-dev   none
GNU Readline Command-line editing library GNU GPL v3.0 libreadline-dev   none
ARPACK Solution of large-scale eigenvalue problems BSD like - various authors libarpack2-dev   none
cURL Library for transferring data with URL syntax Free Software -- main author > 7.32.00 curl   CVE-2013-4545
FFTW3 Library for computing discrete Fourier transforms MIT -- GNU GPL v2.0 libfftw3-dev   none
FLTK Portable GUI toolkit GNU GPL v2.0 with static linking exception libfltk1.3-dev   none
fontconfig Library for configuring and customizing font access Provided "as is" -- various authors fontconfig   none
FreeType Portable font engine compatible with GNU GPL v3.0 libfreetype6-dev   none
GLPK GNU Linear Programming Kit GNU GPL v3.0 libglpk-dev   none
gnuplot Interactive graphics program Provided "as is" -- various authors gnuplot   none
GraphicsMagick++ Image processing library various -- integrates many third-party libs > 1.3.18 libgraphicsmagick++1-dev   CVE-2013-4589
HDF5 Library for manipulating portable data files BSD - like libhdf5-dev   none
OpenGL API for portable 2D and 3D graphics Free specs -- license is driver dependent libgl-dev   none
Qhull Computational geometry library Free software -- specific libqhull-dev   none
QRUPDATE QR factorization updating library GNU GPL v3.0 libqrupdate-dev   none
SuiteSparse Sparse matrix factorization library Main author libsuitesparse-dev   none
zlib Data compression library Provided "as is" -- various authors zlib1g-dev   none


Security concerns

  • CVE-2013-4545 (cURL): solved by version 7.34.00. Upgrade dependencies.
  • CVE-2013-4589 (graphicsmagick): the actual version (1.3.18, released March 9th, 2013), is affected. Awaiting a new release.