Changes

Jump to navigation Jump to search
2,874 bytes added ,  04:26, 6 April 2015
m
Mark bug fixed
* WON'T FIX <strike> Owner: ??? {{bug|44217}} Make name column in the workspace table sortable </strike>
* WON'T FIX <strike> Owner: ??? {{bug|44216}} Bind <RETURN> to double-click in File Browser </strike>* <strike> Owner: ??? {{bug|44204}} Ctrl+C won't interrupt running scripts if Copy shortcut has been changed</strike>
* WON'T FIX <strike> Owner: ??? {{bug|44202}} Some documentation items are accessible using "doc" in cli but not in GUI </strike>
* <strike> Owner: ttl {{bug|44196}} Crash after pressing "apply" when changing shortcuts in the preference dialog </strike>
* WON'T FIX <strike> Owner: ??? {{bug|44174}} Remote X-Window display: command window blank, all other windows fine </strike>
* <strike> Owner: ??? {{bug|44163}} [GUI] Ghost breakpoints in editor* WON'T FIX </strike> Owner: ??? {{bug|44174}}: Remote X-Window display: command window blank, all other windows fine * </strike>* Owner: jwe {{bug|44156}} Don't update GUI Variable Browser Window unless at top-level for performance</strike>* WON'T FIX <strike> Owner: ??? {{bug|44132}} GUI history pane does not sync with history when using history_control("erasedups")</strike>* <strike> Owner: ??? {{bug|44123}} In the command window within the GUI, the cursor lags the of any typed command</strike>* <strike> Owner: ??? ttl {{bug|44103}} Can't open a folder that contains special characters</strike>* WON'T FIX <strike> Owner: ??? {{bug|44056}} Add more columns to the workspace table</strike>* WON'T FIX <strike> Owner: ??? {{bug|44040}} GUIeditor: horizontal scroll bar in editor missingdoesn't quite reach the end of very long lines </strike>* WON'T FIX <strike> Owner: ??? {{bug|43922}} Renaming/deleting a file within the Octave GUI shouldn't trigger the "file has been deleted or renamed"-dialog</strike>* WON'T FIX <strike> Owner: ??? {{bug|43838}} Object browser in debugger</strike>
* <strike> Owner: ??? {{bug|43822}} debugger path conflicts with search path </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43549}} Matlab-style "Set path" menu option in Octave GUI </strike>
* <strike> Owner: ??? {{bug|43520}} Command window hangs </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43467}} Retinize the Script Editor in Octave Mac 3.8.2</strike>
* <strike> Owner: ??? {{bug|43297}} Preferences:Editor:Fonts </strike>
* <strike> Owner: ??? {{bug|43172}} Octave GUI can't close with Exit </strike>
* Owner: ??? {{bug|43099}} utf-8 files: editor, command windows issues, workspace pane shows correctly
* <strike> Owner: ??? {{bug|43096}} GUI workspace pane shows dimension 1x1 for my class</strike>
* WON'T FIX <strike> Owner: ??? {{bug|43079}} GUI display at high resolution </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43076}} CoreText performance note re Postcript font names. </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43058}} Workspace display related fix requested </strike>
* WON'T FIX <strike> Owner: ??? {{bug|42980}} GUI: when undocking editor, focus is in documentation rather than terminal</strike>
* Owner: ??? {{bug|42708}} Breakpoints should be removed from files when changes are saved
* Owner: ??? {{bug|42705}} Commands continue to be sent to the terminal if breakpoint hit
* <strike> Owner: ??? {{bug|42681}} Freeze on Ctrl+s in Console </strike>
* WON'T FIX <strike> Owner: ??? {{bug|42603}} GUI: allow opening an m-file in the editor of a running instance</strike>* WON'T FIX <strike> Owner: ??? {{bug|42602}} GUI Editor could sort tabs alphabetically</strike>
* WON'T FIX <strike> Owner: ??? {{bug|42569}} Glitch in code folding </strike>
* <strike> Owner: ??? ttl {{bug|42307}} Play button does not run script if name contains hyphen</strike>* <strike> Owner: ??? ttl {{bug|42306}} Requests for GUI</strike>* WON'T FIX <strike> Owner: ??? {{bug|42242}} Octave does not always execute most recently saved file in an NFS directory</strike>* WON'T FIX <strike> Owner: ??? {{bug|42136}} Unicode box drawing chars in GUI don't line up very well</strike>
* <strike> Owner: ??? {{bug|41938}} Fonts do not scale properly with 3200x1800 monitors </strike>
* Owner: ??? {{bug|41896}} Octave GUI does not exit normally while the pager "less" is active.
* WON'T FIX <strike> Owner: ??? {{bug|41844}} GUI Debug Menu could offer "Stop If..." </strike>
* Owner: ??? {{bug|41842}} GUI Command Window should show horizontal scroll bar if necessary
* WON'T FIX <strike> Owner: ??? {{bug|41817}} UI crash adding a comment line to an Octave .m file.</strike>
* Owner: ??? {{bug|41798}} GUI Command Window should scroll contents upon mouse selection hitting bottom or top limits
* WON'T FIX <strike> Owner: ??? {{bug|41555}} GUI Editor could offer line wrapping of comment blocks</strike>* WON'T FIX <strike> Owner: ??? {{bug|41554}} GUI Editor could offer auto/smart indentation</strike>* WON'T FIX <strike> Owner: ??? {{bug|41544}} command window could support PgUp/PgDown to look around buffer</strike>* WON'T FIX <strike> Owner: ??? {{bug|41542}} GUI crashes while repositioning dock widgets</strike>* WON'T FIX <strike> Owner: ??? {{bug|41530}} Editor debug mode could show a dbup/dbdown GUI component</strike>* WON'T FIX <strike> Owner: ??? {{bug|41514}} GUI editor can't set breakpoint on class methods</strike>
* WON'T FIX <strike> Owner: ??? {{bug|41472}} command window prompt could allow text selection via keyboard </strike>
* WON'T FIX <strike> Owner: ??? {{bug|41471}} offer search in command window</strike>* WON'T FIX <strike> Owner: ??? {{bug|41470}} offer editor preference "highlight current word"</strike>* WON'T FIX <strike> Owner: ??? {{bug|41443}} support drag & drop</strike>
* <strike> Owner: ??? {{bug|41347}} GUI editor code completion popup blocks keyboard input on RHEL 6 </strike>
* <strike> Owner: ??? {{bug|41282}} GUI Editor: File > New Function shouldn't automatically save function </strike>
* WON'T FIX <strike> Owner: ??? {{bug|41276}} Allow opening files when the function name is displayed in the command window</strike>
* WON'T FIX <strike> Owner: ??? {{bug|41224}} GUI Editor should syntax-highlight test cases </strike>
* WON'T FIX <strike> Owner: ??? {{bug|41199}} GUI Editor could support code sections or cells</strike>* WON'T FIX <strike> Owner: ??? {{bug|41195}} GUI Editor should highlight invalid characters</strike>
* Owner: ??? {{bug|41088}} add a splash screen (loading is non-instantaneous)
* WON'T FIX <strike> Owner: ??? {{bug|41076}} support HTML links in terminal display</strike>* <strike> Owner: ??? lostbard {{bug|41074}} MinGW: avoid showing terminal window while GUI is loading</strike>* WON'T FIX <strike> Owner: ??? {{bug|41073}} GUI should show HTML docs not info docs</strike>
* Owner: ??? {{bug|41072}} GUI: improved locale detection
* <strike> Owner: ??? {{bug|40633}} menus not accessible after changing language settings </strike>
* WON'T FIX <strike> Owner: ??? {{bug|40551}} Support user-configurable template files for new function and oct files</strike>* WON'T FIX <strike> Owner: ??? {{bug|40343}} Suggestion: Add XInitThreads() call before starting the QT based GUI.</strike>* Owner: ??? {{bug|40156}} allow --traditional to set Matlab-compatible default readline keybindings* WON'T FIX <strike> Owner: ??? {{bug|39935}} dialog button order incorrectly changes depending on CLI or GUI</strike>* <strike> Owner: ??? jwe {{bug|39646}} intermediate workspace display overload when executing 'test'</strike>* Owner: ??? {{bug|39179}} octave_qt_link::do_edit_file always returns true even when Warn or fall back to external editor if built without QScintilla not present* <strike> Owner: ??? {{bug|38305}} Conflicts between octave's SIGCHLD handler and qt process handling</strike>* <strike> Owner: ??? {{bug|37401}} Multi-line command recall is weird in GUI editor; non-GUI is OK.</strike>
* <strike> Owner: ??? {{bug|37354}} Add support for multiple octave interpreters in one gui window </strike>
* WON'T FIX <strike> Owner: ??? {{bug|35619}} Link error in 'Terminal' tab with the corresponding m-file</strike>
== Bugs related to Windows OS ==
* <strike> Owner: ??? {{bug|44206}} test complex.tst fails in MXE-octave</strike>* <strike> Owner: ??? rik {{bug|44125}} mxe-octave: fltk printing displays line dropouts in dev version</strike>* <strike> Owner: ??? {{bug|44118}} imwrite saves wrong pixel values into jpg file</strike>* <strike> Owner: ??? {{bug|44075}} buid mxe-octave fails "Failed to build package nsis"</strike>* <strike> Owner: ??? {{bug|43979}} test unpack fails in MXE-Octave ver 4.1.0+</strike>
* WON'T FIX <strike> Owner: ??? {{bug|43651}} special character (diameter sign) in plot produces warning or doesn't show up </strike>
* <strike> Owner: ??? {{bug|43525}} mxe-octave: compile with OpenBLAS with OMP enabled</strike>* WON'T FIX <strike> Owner: ??? {{bug|43318}} [MinGW] "unknown type name 'int64_t'" with --enable-64 when compiling some OF packages</strike>
* Owner: ??? {{bug|43036}} popen2 on Windows fails quietly if command writes to stderr
* Owner: ??? {{bug|42534}} No lines when printing fltk plot with Intel graphics on Windows
* Owner: ??? {{bug|41129}} similar warnings repeated over and over while loading OF pkgs
* WON'T FIX <strike> Owner: ??? {{bug|40726}} <Tab> complete uses incorrect file separator on Windows </strike>
* WON'T FIX <strike> Owner: ??? {{bug|40444}} On Windows, config & history files etc. should go to %APPDATA%</strike>
* <strike> Owner: ??? {{bug|40443}} MinGW: Octave crashes on exit after GraphicsMagick tests </strike>
* WON'T FIX <strike> Owner: ??? {{bug|39856}} Cannot compile an Oct-File in Windows 7 64 or Vista 64 oct file</strike>* WON'T FIX <strike> Owner: ??? {{bug|39004}} GUI: limitations of selecting text in terminal widget in Windows</strike>* WON'T FIX <strike> Owner: ??? {{bug|37053}} Saveas & Print error when saving as .emf </strike>
* WON'T FIX <strike> Owner: ??? {{Bug|36677}} make_absolute_filename: extend to work with Windows drive letters </strike>
* <strike> Owner: lostbard {{bug|44145}} MXE-octave - cannot download gmp lib </strike>
* <strike> Owner: ??? {{bug|44060}}: audiodevinfo fails to build on updated fedora 20 </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43908}} Some OF packages won't install with 64-bit indexing Octave</strike>* WON'T FIX <strike> Owner: ??? {{bug|43562}} Compilation failed on Mac OS X Yosemite</strike>* WON'T FIX <strike> Owner: ??? {{bug|43505}} build gm with quantum-depth=16 in mxe octave</strike>* WON'T FIX <strike> Owner: ??? {{bug|43298}} LLVM 3.5.0 cannot resolve the pow(octave_int<int>, octave_Int<int>) function overload</strike>* <strike> Owner: mtm {{bug|43279}} Please install the supplied AppData file</strike>
* WON'T FIX <strike> Owner: ??? {{bug|43250}} Octave fails to build with Intel Compiler </strike>
* <strike> Owner: mtm {{bug|43087}} improve support for reproducible builds</strike>* <strike> Owner: ??? mtm {{bug|43063}} Suitesparse 4.3.x has changed APIs, no longer builds with Octave</strike>
* <strike> Owner: ??? {{bug|43003}} polyfit error.... 64 bit problem? </strike>
* <strike> Owner: ??? {{bug|42995}} building Octave with SGI MipsPro 7.3 CC </strike>
* <strike> Owner: mtm {{bug|42176}} Octave built without OpenMP crashes when unloading OpenMP-enabled oct-files</strike>
* WON'T FIX <strike> Owner: ??? {{bug|42057}} qMin compilation error with --enable-64 </strike>
* <strike> Owner: rik {{bug|41665}} 'qt' is default graphics toolkit even when it is not available </strike>
* <strike> Owner: ??? rik {{bug|41636}} mkoctfile doesn't accept -std=c++11 option</strike>
* WON'T FIX <strike> Owner: ??? {{bug|41298}} pkg install: automatically extract %!tests and install both extracted and fixed test files </strike>
* WON'T FIX <strike> Owner: ??? {{bug|41155}} Java does not work with binary installer for Mac OS</strike>
* WON'T FIX <strike> Owner: ??? {{bug|41102}} mxe-octave: path inconsistency when building in a symlinked path </strike>
* WON'T FIX <strike> Owner: ??? {{bug|41061}} Octave fails to build with LLVM 3.4 and 3.5-pre-release </strike>
* Owner: ??? {{bug|41027}} config.h is too generic
* WON'T FIX <strike> Owner: ??? {{bug|40273}} 'sed' is used even if a different value for 'SED' is specified during configure </strike>
* WON'T FIX <strike> Owner: mtm {{bug|40252}} Make GUI compatible with both Qt4 and Qt5</strike>* WON'T FIX <strike> Owner: ??? {{bug|40111}} Support runtime selection of Java version on Linux and Unix systems</strike>
* WON'T FIX <strike> Owner: ??? {{bug|39446}} MXE-Octave: LAPACK build mixes MinGW and MSVC </strike>
* WON'T FIX <strike> Owner: ??? {{bug|38776}} Tests in private functions cannot be tested directly </strike>
* <strike> Owner: ??? mtm {{bug|37062}} hi-res icon</strike>* <strike> Owner: ??? {{bug|36943}} documentation not built without gnuplot</strike>
* WON'T FIX <strike> Owner: rik {{bug|36524}} Upgrade defun macro to accept non-double-quoted string for DOCSTRING </strike>
* WON'T FIX <strike> Owner: ??? {{bug|36477}} use XDG dirs instead of HOME</strike>* WON'T FIX <strike> Owner: ??? {{bug|34301}} Can't compile oct files using gcc -fvisibility=hidden option</strike>* <strike> Owner: ??? rik {{bug|34169}} Support -f compiler flags in mkoctfile</strike>
== Bugs with severity >= 4 ==
* <strike> Owner: ??? {{bug|44330}} Qt toolkit segmentation fault when figure opened, closed, and opened again </strike>* <strike> Owner: ??? {{bug|44296}} Windows segmentation fault with dl.exe </strike>* Owner: ??? {{bug|44292}} Frequent crashes when printing to eps on Windows platform* <strike> Owner: lostbard {{bug|44215}} README.html for NSIS install needs update</strike> * <strike> Owner: ??? {{bug|44186}} print command gives incorrect postscript file </strike>* <strike> Owner: jwe {{bug|44015}} GUI crashes after clear all in right click menu</strike>
* Owner: ??? {{bug|43769}} error: invalid meta.package indexing when using strfind function
* <strike> Owner: ??? {{bug|43741}} different results from power operator in mxe-octave GUI/CLI</strike>* WON'T FIX <strike> Owner: ??? {{bug|42596}} OpenGL toolkits for the GUI on MacOS X</strike>* <strike> Owner: jwe {{bug|42537}} print backend needed for qt toolkit</strike>* WON'T FIX <strike> Owner: ??? {{bug|42469}} GUI crashes on international character after autocompletion</strike>* <strike> Owner: jwe {{bug|41977}} '__qt_ginput__' not found </strike>
* Owner: ??? {{bug|41699}} imformats causes a segmentation fault on Windows when Octave exits
* WON'T FIX <strike> Owner: ??? {{bug|40545}} Opening preferences causes the GUI to hang forever on OSX 10.9</strike>* WON'T FIX <strike> Owner: ??? {{bug|40498}} opening or saving files crashes the GUI on OSX</strike>* WON'T FIX <strike> Owner: ??? {{bug|40242}} FLTK + GUI = crash on MacOSX</strike>
* Owner: ??? {{bug|39000}} Can't override BLAS XERBLA handler on Windows
* Owner: ??? {{bug|37672}} GUI doesn't react to CTRL+C
* WON'T FIX <strike> Owner: ??? {{bug|35857}} Octave crashes when plotting with units = normalized</strike>
== Bugs marked as regressions ==
* <strike> Owner: jwe {{bug|44245}} sprintf ("%0X", 15.2) prints floating point number 15.2 rather than 'F' </strike>* WON'T FIX <strike> Owner: ??? {{bug|44195}} segfault with dbstatus</strike>
* WON'T FIX <strike> Owner: ??? {{bug|44152}} print("plot_file.pdf") generates warning message </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43585}} rectangle wrong axis calculation</strike>
* <strike> Owner: ??? {{bug|43559}} "hold on" causes "plot" to use incorrect series colouring </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43511}} null array retained when cellstr is used to build vector through concatenation</strike>* <strike> Owner: ??? {{bug|43064}} Missing subplot in legend demo 29-33</strike>* WON'T FIX <strike> Owner: ??? {{bug|42825}} Memory corruption in sparse matrix operation</strike>
* <strike> Owner: ??? {{bug|42716}} Transpose multiply not detected </strike>
* <strike> Owner: ??? {{bug|42612}} clf after subplot with "outside" legend gives "error: invalid handle"</strike>* <strike> Owner: ??? {{bug|42474}} saving jpg images with imwrite changes image</strike>
* <strike> Owner: ??? {{bug|42314}} Matrix transpose multiply performance regression </strike>
* <strike> Owner: ??? {{bug|42248}} echo_executing_commands does not echo when executing from stdin </strike>
* <strike> Owner: ??? jwe {{bug|42235}} "invalid conversion from string to real scalar" with %c, %d, %f, etc.</strike>* WON'T FIX <strike> Owner: ??? {{bug|41574}} Current build approach causes mkoctfile to link to too many libraries on the Mac (patch supplied)</strike>* WON'T FIX <strike> Owner: ??? {{bug|41512}} max() of sparse logical matrix fails</strike>
* <strike> Owner: ??? {{bug|41312}} latest Jit patch causes test jit failures </strike>
* <strike> Owner: ??? pantxo {{bug|41128}} In fltk backend, subplot(M,N,n) does not work in condition 4<M.</strike>* WON'T FIX <strike> Owner: ??? {{bug|40333}} print with legend modifies axis position (gnuplot)</strike>
* WON'T FIX <strike> Owner: ??? {{bug|38236}} invoking script in demo block to define variables causes errors </strike>
* WON'T FIX <strike> Owner: ??? {{bug|31287}} Certain assignments of empty arrays give errors (Matlab incompatibility)</strike>
== Bugs marked as Crash ==
* <strike> Owner: ??? {{bug|44089}} octave uses complete RAM on print command </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43968}} print / save FLTK figure crashes Octave</strike>
* <strike> Owner: ??? {{bug|43941}} Crashes immediately on startup </strike>
* WON'T FIX <strike> Owner: ??? {{bug|43740}} GUI + FLTK + MacOSX -> Crash / Signal 11</strike>* WON'T FIX <strike> Owner: ??? {{bug|42850}} Reshape on sparse matrix leads to segfault</strike>
* WON'T FIX <strike> Owner: ??? {{bug|42429}} @ftp/dir crashes Octave </strike>
* WON'T FIX <strike> Owner: ??? {{bug|42424}} crash when "find" on sparse matrices is given at least 6 return-values</strike>
* WON'T FIX <strike> Owner: ??? {{bug|42118}} COW memory issues when extracting small slices from large arrays </strike>
* <strike> Owner: ??? {{bug|42017}} Plot command fails after exiting gnuplot </strike>
* <strike> Owner: ??? {{bug|40924}} MSVC Octave crashes inverting complex matrix with OpenBLAS </strike>
* <strike> Owner: ??? {{bug|40608}} MinGW: crashes with JIT </strike>
* WON'T FIX <strike> Owner: ??? {{bug|40362}} chi2cdf/gamcdf/gammainc bug</strike>
* WON'T FIX <strike> Owner: ??? {{bug|40121}} Using dbquit from within a callback causes a segfault </strike>
* WON'T FIX <strike> Owner: ??? {{bug|40044}} *** glibc detected *** gnuplot: double free or corruption (fasttop): 0x08d72878 *** </strike>
* <strike> Owner: ??? {{bug|38280}} imfinfo() crashes on 64 bit, but not 32 bit builds</strike>
* <strike> Owner: ??? {{bug|37205}} running JIT tests with valgrind: possible memory issues and segfault </strike>
* WON'T FIX <strike> Owner: ??? {{bug|36067}} bug in exist() when checking for a faulty mex/oct file </strike>
911

edits

Navigation menu