Changes

Jump to navigation Jump to search

Bug Fix List - 5.0 Release

829 bytes added, 15 February
m
Add new bug
== Bugs marked as Crash ==
 
* Owner: ??? {{bug|55647}} crash, hang, error or corrupted output when printing some demos to EPS
 
* WON'T FIX <strike> Owner: ??? {{bug|55630}} macOS GUI freezes on launch </strike>
* WON'T FIX <strike> Owner: ??? {{bug|55547}} libstdc++ assertion failure when built with -D_GLIBCXX_ASSERTIONS=1 </strike>
* WON'T FIX <strike> Owner: ??? {{bug|55523}} segfault when default argument of anonymous/nested function is the same name as argument</strike>
* WON'T FIX <strike> Owner: ??? {{bug|55492}} "make check" crashes with jit (llvm 4.0.1) </strike>
* <strike> Owner: ??? {{bug|55397}} test imwrite error with address sanitizer </strike>
* <strike> Owner: ??? {{bug|55375}} [MXE Octave] crash after plot</strike>
* <strike> Owner: ??? {{bug|55287}} Memory leak in graphics subsystem </strike>
* <strike> Owner: ??? {{bug|55258}} Recursion in a script file causes a segmentation fault</strike>
* <strike> Owner: ??? {{bug|55254}} clear all crashes when variable from oct file class is displayed in workspace </strike>
* Owner: ??? {{bug|55053}} GUI hanging when editing and saving function file during debugging
* <strike> Owner: ??? {{bug|55047}} Running the test suite causes Octave to segfault on Windows</strike>
* <strike>Owner: ??? {{bug|55028}} plots executed from script containing many plots seg fault</strike>
* <strike> Owner: ??? {{bug|49736}} GUI: Crash when attempting to use the editor after too many files are opened </strike>
* <strike> Owner: ??? {{bug|49702}} CTRL+C crashes Octave CLI in Homebrew</strike>
* Owner: ??? {{bug|49109}} child process started by fork crashes or hangs with octave-gui
== Bugs marked Configuration and Build System ==
 
* <strike> Owner: ??? {{bug|55545}} [MXE Octave] Update mesa to 18.2.8 </strike>
* Owner: ??? {{bug|55538}} logspace BIST tests fail when Octave built with LLVM libc++
* <strike> Owner: ??? {{bug|55447}} mkoctfile: wrong LFLAGS warning, resets LDFLAGS</strike>
* WON'T FIX <strike> Owner: ??? {{bug|55371}} Add configure flag to specify makeinfo path </strike>
== Bugs marked as Build Failure ==
 
* Owner: ??? {{bug|55641}} mxe-octave: build error of-general w. Octave-6.0.0
 
* <strike> Owner: ??? {{bug|55613}} Build failure with bison 3.3.1 </strike>
 
* Owner: ??? {{bug|55608}} [MXE Octave] lib vs lib64
* WON'T FIX <strike> Owner: ??? {{bug|55367}} Linking fails on cygwin </strike>
== Bugs marked as regressions ==
* <strike> Owner: ??? {{bug|55648}} [MXE-Octave] cannot print with gnuplot graphics toolkit </strike> * Owner: ??? {{bug|55622}} for loop does not run over a matrix with colums but no row * <strike> Owner: ??? {{bug|55529}} [MXE Octave] running compare_plot_demos ("toolkits", "qt") hangs Octave</strike>
* <strike> Owner: ??? {{bug|55528}} [MXE-Octave] graphics_toolkit gnuplot does not work</strike>
* <strike> Owner: ??? {{bug|55501}} subsequent calls to "help @sym/beta" gives "help beta" text </strike>
900

edits

Navigation menu