MXE

From Octave
Jump to: navigation, search

Based on the MXE project there is an MXE-Octave fork available to allow cross compiling Octave to various target systems.

Examples of compiling Octave for different platforms[edit]

  • Compiling for Windows
  1. There is some further information for using mxe-octave to build an Windows installer here: Windows_Installer.

MXE-Octave is really intended to be used to cross compile Octave along with all dependencies for Windows systems. It may also be used to do native builds on Windows if you have a minimal set of MinGW tools installed, or to do native builds on Linux systems. However, it was really only intended as a way to build Octave on systems that lack sufficiently recent versions of tools and libraries to build Octave.

For systems that provide packages of recent versions of GCC and required build dependencies, MXE-Octave is NOT the best choice for building Octave.

  • Compiling for your Linux system
  1. Download MXE-Octave as a compressed file.
  2. Unpack it in ~ or somewhere suitable.
  3. Check you have all the requirements, gfortran and libgl2ps-dev.
  4. cd into the directory (called ~/mxe-octave-123456789 or similiar).
  5. Type: autoconf
  6. Type: ./configure --enable-64 --enable-native-build --enable-pic-flag host_alias=gnu-linux --enable-openblas --enable-jit
  7. Type: make
  8. Type: make openblas
  9. cd usr/lib
  10. mv libblas.so libblas.so.reference
  11. ln -s libopenblas.so libblas.so
  12. Octave will exist in ~/mxe-octave-123456789/usr/bin
  13. Add to your .bashrc file: alias octave=~/mxe-octave-123456789/usr/bin/octave

It's that easy...

  • Compiling for your Ubuntu Desktop x64 Linux (tested for 14.xx)
  1. In Ubuntu Desktop Linux 14.10 the above receipt fails during building BLAS library ...
  2. I have found a working solution how to build Octave 3.8.2 with ---enable-64 in Ubuntu Desktop Linux - see:
  3. BLOG: http://calaba.tumblr.com/post/107087607479/octave-64
  4. GitHub: https://github.com/calaba/octave-3.8.2-enable-64-ubuntu-14.04
  • Compiling for a different Linux system
  1. ...

Packaging for distribution[edit]

Note for gnuplot[edit]

The gnuplot built by mxe-octave does not support cairo based terminals and lua/tikz terminals. If you want uses those feature, prepare gnuplot with those features and points its location setting to "gnuplot_binary" like

 >> gnuplot_binary /usr/bin/gnuplot